
Building A Web Application With Flash

Introduction
Overview Of Our Presentation

Our presentation is divided into five major parts

1. Basics of Flash

2. Developing Flash Application in Flash MX

3. Animating with Flash

4. Advanced back-end interfaces with Flash

5. Using Google in Flash and some flash demos

The Basics Of Flash
What is Flash?

Macromedia Flash is a Web technology for creating graphics   

and animation on Web pages or standalone application. 

It has quickly become the premier Web software for animated  

graphic presentations due to its bandwidth-friendly and     

browser-independent vector-

graphic technology.

Now with the latest version, Macromedia Flash is also able to  

communicate back and forth with a database. You can send   

information from a database to the movie and vice versa. 

The Flash Player
Is a standalone program that is separate from the Flash program that is  

use to create Flash movies. 

Flash movie files contain the instructions that tell the Flash Player how 

to reproduce the images, animations, sound effects, and so on.

To play back a Flash movie, you need a copy of the Flash Player but   

virtually all Web browsers already have some version of the Flash   

Player built in.

Both Internet Explorer and Netscape Navigator utilize a specific plug-in 

made for that particular browser, allowing Flash animations to look the    

same on any platform. 

The Basics Of Flash
Some Advantages Of Using  Flash

One of the great advantages of using Flash is that fact that you can provide 

engaging content with a minimal wait time. For example the image shown below    

which is made Flash only takes about 1K of storage.

Most multimedia formats can be integrated into Flash. You can use vector 

formats, such as EPS (Encapsulated PostScript), and files from FreeHand and 

Illustrator. You can even use bitmaps, such as GIF, TIF, JPEG, and PNG. You   

can also use sound formats, such as WAV, AIF, and MP3, and AVI and MOV  

movie formats.
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Major Components Of Flash MX

The Basics Of Flash
Major Components Of Flash MX

The Flash Stage: The stage is the area where you add objects that you want   

to appear in your Flash movies. 

The Timeline: The timeline is the controller for all of your Flash movies. The  

timeline is made up of frames that play at a specific time during the movie. 

Layers: Layers are simply different areas that are stacked onto the Flash 

workspace. 

The ToolBox: The toolbox contains all the tools you need for drawing objects 

on the stage. 

The Panels: Flash has several panels-which can remain on the screen ready 

for additional use without requiring you to respond to them.
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Developing Flash Application 
Using Flash MX 2004

Drawing Tools, UI Components, 
Actionscripts

Flash MX 2004

Flash MX 2004 offers simple 
drawing tools to design the 
appearance for any flash application, 
animation, presentation, etc.
The component panel allows the 
user to drag a component (eg. 
Button) onto the working area.
Action panel let the user to enter 
actionscripts for any elements on 
the screen.



Actionscripts

Actionscripts are typically used to 
define actions to an element when 
an event occur.
The syntax are very similar to 
javascripts.
It has some built-in classes and 
methods that we can use.
Can define a new class of objects 
and methods just like Java.

Developing an Application

Drawing
Tool Box

Component
Panel

Properties 
Panel

Input Text Box

Dynamic Text

Developing an Application

Properties of the 
input textbox

Developing an Application

Dynamic Text

Instance name of 
the element



Developing an Application

Drag a button to 
position

Properties for the 
button

Developing an Application

Rename the label and 
the instance name

The tap for the 
actions panel

Developing an Application

Enter actionscripts

Built-in functions and 
classes

Existing 
elements

Developing an Application

Check the script 
for errors



Developing an Application

Helping box pops 
out automatically

Developing an Application

The script for the 
calculate button

Developing an Application

Test the 
application

Why people use animation on web.

Flash today is the most popular eye 
candy maker .

Easy to use application + Vector 
graphics

Animating with Flash



Vector Based Graphics:

What is Vector Based Graphics.
Flexibility + size advantage over 

bitmap.

Making animation:

What is a key frame and layers ?

How is the movie constructed?

What is motion tween
http://www.ualberta.ca/~syeh/test.html

Auto generated frames

'Insert> Create Motion Tween’ + F6

Enter to run the movie

Motion Tween



Animation with Sounds

Play sound at at the right moment

Standard sound library

Self imported sound files, mp3, 
midi etc.



Import Flash in to your html

To Export your movie, so you can 
use it on your web page:

Go to 'File> Export Movie' and 
save your movie as what you want. 
Flash movies usually are saved 
as .swf format.

<html>
<head>
</head>
<body>
<EMBED SRC="movie.swf"
QUALITY="high“ 

PLUGINSPAGE="http://www.macromedia.com/sh
ockwave/download/index.cgi?P1_Prod_Version=S
hockwaveFlash" TYPE="application/x-shockwave-
flash" WIDTH=“400" HEIGHT=“120">

</body>
</html>

Integrating External Data
Sources in Flash
Connecting external data sources for use in flash   

applications
E.g. database

Implemented in four layers:
Data Connectivity
Data Management

Data Resolution
Data Binding

The Data Connectivity Layer
Data transport layer provided through :

Flash components
Actionscript

Supported methods:
Web Services
Pure XML via HTTP
Flash Remoting binary protocol (developed 

exclusively for Flash)



The Data Management Layer
manage data on the client via the DataSet

component
DataSet:

Flash object 

A miniature database (really an array)

Data within the DataSet can be sorted, filtered, 
searched, etc. via provided methods

The Data Resolution Layer
DeltaPacket

Flash object

constructed from locally changed data

use RDBMSResolver component to create 
packages that can be decomposed to SQL 
statements

use XUpdate component to create XUpdate
XML packet (XML standard)



The Data Binding Layer
binds one component with another component.

changes in one component will be reflected in the 

other.

The link between the Flash application’s  

interface   and its DataSets

Building a Google Search Application 

with Macromedia Flash MX Professional

Goal

Create a simple web search application that    

queries the Google web API using SOAP   

web services.

Building a Google Search Application with 

Macromedia Flash MX Professional

Building a Google Search Application with 

Macromedia Flash MX Professional

Four main steps :

A) Create the framework for the Flash form application

B) Connect to Data Sources with Components

C) Attach Script Actions

D) Publish the Application



Building a Google Search Application with 

Macromedia Flash MX Professional

A) Create the framework for the Flash form application:

Choose File > New and select Flash Form Application. This creates a default       

application with two nested form screens. 

In the Property inspector of form1, change the instance name to frmSearch.   

This form will contain the main search interface. 

Right-click frmSearch and choose Insert Nested Screen. This creates a new  

form screen called form2 underneath frmSearch. Change the instance name of  

the new form screen to frmLoading. 

Building a Google Search Application with Macromedia Flash MX Professional

Building a Google Search Application with 

Macromedia Flash MX Professional

Now you can add UI components to the forms. In the Components panel, 

drag a Label, Button TextInput, and TextArea component onto the stage. 

Using the Property inspector, give the components the following instance  

names—Label: lblSearchTime; Button: btnSearch; TextInput: txtQuery; 

and TextArea: txtResults. 

Building a Google Search Application with Macromedia Flash MX Professional



Building a Google Search Application with 

Macromedia Flash MX Professional

Add an animated "loading" element that lets the user know the search is 

executing:

Select the frmLoading form screen. 

Add a text tool element (that says "Loading..."), then add a Timeline Effect. 

To   

do this, right click the text tool element you created  and choose > Timeline   

Effects > Effects and then your selected effect to create an animation without  

any authoring at all. 

To prevent the loading widget from appearing,  select frmLoading and change   

the visible property in the Parameters inspector to false. Later we'll make this  

screen visible with ActionScript while the search is executing. 
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Building a Google Search Application with 

Macromedia Flash MX Professional

B) Connecting to Data Sources with Components

To connect your application to the Google search service:

Drag a WebServiceConnector component from the Components panel 

to the  form screen. It doesn't matter where you put it - the component 

won't be visible in the published application. Give the component an 

instance name of GoogleSearch. 

Building a Google Search Application with Macromedia Flash MX Professional



Building a Google Search Application with Macromedia 

Flash MX Professional

Select the GoogleSearch component and open the Component inspector. This   

is where you establish the web service settings. Select the Parameters tab              

and set the WSDLURL parameter to Google's WSDL URI     

(http://api.google.com/GoogleSearch.wsdl). Flash automatically queries the  

service and retrieves its available operations. 

- From the operations pop-up menu, select doGoogleSearch .

Building a Google Search Application with Macromedia Flash MX Professional

Building a Google Search Application with Macromedia 

Flash MX Professional

The Bindings tab in the Component inspector allows you to bind the web   

service inputs and outputs directly to a UI component in the application.

Click the + icon to choose which parameters to bind. Input parameters are   

indicated by a right arrow and output parameters by a left arrow .  The   

Google interface requires all these input parameters. We are  also binding     

one output parameter, results.searchTime . 

Building a Google Search Application with Macromedia Flash MX Professional



Building a Google Search Application with Macromedia 

Flash MX Professional

For each binding in the list, you need to set a UI component, a variable 

reference, or a literal value to pass to or from the web service.

For instance, to bind params.q (the search query string to pass to the Google

service) to the TextInput component on the frmSearch form, select params.q

from the binding list and click the "find" icon in the Bound To row . 

In Bound To dialog box, which displays a hierarchical list of components in  

your application, select txtQuery component instance. 

Building a Google Search Application with Macromedia Flash MX Professional

Building a Google Search Application with Macromedia 

Flash MX Professional

Similarly, we fill in the rest of the input parameters for the Google service. 

C) Attaching Script Actions

ActionScript 2 is used to associate behaviour with components.

To trigger the web service and display its results:

Click the btnSearch button on frmSearch.

In the Behaviors panel, click the + icon and choose Data > Trigger Data    

Source.  - In the resulting dialog box, select GoogleSearch

WebServiceConnector

Building a Google Search Application with Macromedia Flash MX Professional



Building a Google Search Application with Macromedia 

Flash MX Professional

Now when the user clicks the Search button the web service is triggered. 

Web service output  which we can’t bind in the Component inspector must  

be handled with code. 

For instance, add event listeners which allow us to intercept the web 

service's send and result events and perform additional operations with 

ActionScript. 

Add the ActionScript functions that handle these events. 

In particular, enable/disable components while the search is in progress

iterates through the results returned from Google, format them using HTML, 

and display them in the txtResults TextArea .

Building a Google Search Application with Macromedia 

Flash MX Professional

D) Publishing the Application

File > Publish 

Some Flash Links

www.2advanced.com

www.eye4u.com


