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Making a Sword (in your world) 
 
“Making a sword?” you say, “What’s the big deal?”  Well, making a sword in a few 
hours at the anvil is child’s play, but making a sword with your computer, that’s 
something else entirely.  The goal of this tutorial is to make a sword using Discreet’s 3d 
modeling software, gMax, put some textures on it to make it look more realistic, and 
finally, import it into Neverwinter Nights so you can stab goblins with your own sword. 
 
Author’s Note: This is a very introductory tutorial that takes you step-by-specific-step 
through the process of modeling and texturing.  Things are kept simple to ensure that 
there are few errors in this long and complex process.  Please follow the tutorial closely 
on your first try (using single-polygon blades, stock textures, etc.) and once you’ve got a 
working, textured sword into the game then you can come back and experiment to your 
heart’s delight. 
 
Glossary: 
gMax is a big and powerful program (even if it’s the little brother of 3dStudio Max), so 
much of what it can do will be ignored by this tutorial.  This is a list of terms that will be 
used throughout the tutorial and a short definition for each to provide you with a running 
start when we get into the dirty details of using the program. 
 
Generic terms: 
 
textbox: a box that allows you to type things into it.  They usually look something like 
this: .  This textbox also has up and down arrows to make the number go 
up or down respectively. 
 
dropdown or combo box: this is just a way of choosing an item from a list, and they look 

like this: . 
 
gMax-specific terms: 
 
rollout: the green bars that look like this: .  They can be “rolled 
out” by clicking on them (if they show a plus sign as in the screen shot) or they can be 
rolled in (if they show a minus sign).  The tutorial won’t always tell you to expand a 
rollout, but it will always tell you which rollout a particular button or setting is located in.  
This is what the NWmax rollout looks like when it’s expanded: 
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flyout: this is like a graphical dropdown where icons “drop down” (and sometimes up) 
instead of text.  If an icon has a flyout, it will have this little arrow in the corner ( ).  It 
can be hard to see, so here’s a shot of an icon with a flyout: .  The flyout indicator is in 
the bottom right corner.  To access the flyout, just click and hold the left mouse button 
until the flyout appears and choose the icon that you want.  Here is the same icon with the 

flyout showing: . 
 
tooltips: these are the tips that show up in little yellow boxes when you leave your mouse 
cursor over a button or an icon for a few seconds.  These tips let you know what that 
button or icon is called.  They are quite useful in flyouts as many of the icons look the 
same but are named differently and have different functions.  Here is the tooltip for the 

“Zoom Extents All” icon used in the flyout example: .  The tutorial will 
often suggest using flyouts and tooltips together as it isn’t easy to adequately describe the 
icon you are supposed to use, but the tutorial will always use the icons correct name 
which will show up in the tooltip.  Just keep trying each item in the flyout and checking 
its tooltip until you find the right one. 
 
viewport: these are the four big squares that you see when you open gMax.  They are 
labeled Top, Front, Left, and Perspective.  The best way to change viewports is to use the 
right mouse button.  This way, any selection you may have (say you’ve got your sword 
blade selected) will be preserved when you switch viewports.  Your “active” or 
“selected” viewport is indicated by a thin, light grey line around it (the screenshot in step 
5 shows a selected Perspective viewport).  This is what the Perspective viewport looks 
like: 
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Menus, Toolbars, etc: 
 
menu bar: this is the grey bar at the top of the window that has things like File, Edit 
Tools, etc.  When I say “under the File menu,” I’m talking about left clicking on the File 
menu (in the menu bar).  This is what the bar looks like: 
 

  
 
main toolbar: this is the toolbar that sits right below the menu bar and provides the 
“main” tools.  It’s too long to show in a single screenshot, so here is enough of it so that it 
may be identified: 
 

 
 
command panel: the bar in the top-right corner of the gMax window that has six tabs and 

looks like this: .  It’s called the “command” panel as many of 
the gMax’s functions and tools are found here. 
 
navigation tools: this is a group of tools in the bottom right corner of the gMax window.  

These are used for, you guessed it, navigation, and they look like this: . 
 
quad menu: this menu is opened by right-clicking in one of the viewports and provides 
quick access to many useful tools.  It looks like this: 
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Getting Started 
 
1) Open NWMax (this is just a slightly modified version of gMax which is specially 
formulated for maximum NWN action).  The tutorial will still refer to this program as 
gMax though.  
 
2) Under the “File” menu, choose “Reset” to make sure that all settings are back to their 
defaults. 
 
3) You should see a window labeled “Nwmax”.  Expand the “MDL Loading” rollout, 
click the “Browse” button, and navigate to the pre-downloaded, pre-uncompressed NWN 
model library located at 
C:\NWNScratch\weaponslib\WeaponInfo\MDLsAndIcons\SwordLongSword.  Choose 
the file “wswls_b_011.MDL”.  Don’t worry, the meaning of all of that mumbo jumbo 
will be explained later.  For now, the “b” in the filename means the “bottom” of the 
sword or the grip (and pommel if you want to get specific).  When you’ve selected the 
correct file, click the “Open” button. 
 
4) Back in the NWmax window, click the "Import" button (in the “MDL Loading” 
rollout).  There are a number of import settings, but we’re going to ignore them because 
the defaults are sufficient for our purposes. 
 
5) Repeat steps 3 and 4 to import the “m” or middle piece (the cross piece) and the “t” or 
top piece (the blade) of your sword.  The reason we are importing a ready-made sword is 
so that all the parts will be in the right places and will be the right sizes.  NWN is 
sensitive to how big things are and where they are placed in gMax.  If we use an existing 
sword as a guide, we can avoid many of these concerns.  We should now have a complete 
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sword sitting in gMax just waiting for us to play with.  Here’s a screenshot that shows all 
of the viewports.  From now on, to show you what your gMax should look like, only the 
Perspective viewport will be shown unless others are more relevant. 

 
 
6) Click the "Zoom extents all" button in the navigation tools (looks like this: ).  You 
may need to use the flyout and some tooltips to find this tool.  This will center your 
sword in all the viewports and zoom them all to the same level. 
 
7) Make sure you’ve got the selection tool selected from the main toolbar (shown here 

selected: .  Don’t panic if yours isn’t orange, it will change colour when you click 
on it to indicate that you’ve selected it).  By clicking and dragging, draw a box around the 
sword in the “Perspective” viewport to select it.  In gMax, selection is indicated by little 
white lines around the selection.  You can see the difference “selecting” makes by 
comparing the “Perspective” viewport above to the one below which shows the sword 
selected. 
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8) Let’s take this opportunity to show you how to navigate around the viewports.  
Shockingly, we’ll be using the navigation tools to do so.  There are two tools we’re going 
to focus on (but feel free to experiment with the others on your own).  The first is the 
"Arc Rotate" tool which is located on the second row, second from right and looks like 
this: .  Again, it’s in a flyout and you may have to try a few of the icons until you find 
it.  When you’ve clicked on the tool, you should see that a yellow circle appears in your 
active viewport.  This would be a good time to select the “Perspective” viewport as your 
active viewport.  You can use the others if you like, but “Perspective” seems to be the 
best for getting a sense of what your model will look like in the game.  The best way to 
learn this tool is just to try it out.  So put your mouse cursor into the “Perspective” 
viewport.  You’ll notice that the cursor changes immediately to an arrow (or two) that 
indicate which axis you can rotate on.  Click and hold your left mouse button then drag 
your mouse around.  Play with this for a while until you get comfortable rotating your 
view of the model (use the scroll button on the mouse to zoom).  Clicking on different 
areas in the viewport (like on the yellow squares around the circle that look like this: ) 
will allow different axis of rotation.  It may sound complicated, but just try it out, and 
you’ll be rotating in no time.  This is the “Perspective” viewport with the “Arc Rotate” 
tool enabled: 
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9) The second navigation tool is the “Pan” tool.  It’s also located in the bottom right 

corner of the screen (in the navigation tools section), and looks like this: .  Its motion 
is difficult to describe, but it works similarly to the “Arc Rotate” tool, just left-click in the 
“Perspective” (or any) viewport, and drag your mouse around.  Using the tools I’ve just 
described, orient the viewport so that you have a good view of the sword like in 
following screenshot. 
 

 
 
10) Now that we’ve got our “guide sword” imported and ready to go, we're going to 
freeze it so that we can work without messing with it.  Freezing in gMax simply means 
that you can’t select it (but you can still see it).  Click the "Select by Object" button 

(you’ll find it in the main toolbar, and it looks like this: ) and draw a selection box 
(using the left-click and drag technique) around your sword. 
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11) Then click the “Display” tab (it’s in the command panel in the top right of the screen 

and looks like this: ). 
 
12) Scroll down to the “Freeze” rollout and expand it. 
 
13) Click the "Freeze Selected" button.  This should turn everything a dark bluish grey 
colour, and you won’t be able to select anything.  Here’s what it should look like: 
 

 
 
Actually Making the Sword 
 
14) Select the “Front” viewport and zoom in so that you’ve got a close up view of the 
sword. 
15) Click the “Create” tab (you’ll find it in the command panel, and it looks like this: 

), and click the “Cylinder” button under the “Object Type” rollout. 
 
16) Let’s take a second to discuss how objects are made in gMax.  There are many ways, 
but we’re going to focus on one of the easier ones.  After selecting an object type 
(“Cylinder” for us), when we put our cursor into the viewport, we see that it has changed 

to a cross ( ) instead of a regular arrow cursor.  Objects are made in three actions (all 
based on the left mouse button): origin (the center point of the circle at the base of our 
cylinder), radius (the size of the circle at the base of our cylinder), and height (of our 
cylinder).  The first click (and hold) places the origin. Dragging with that first click is the 
radius (in our case, this will be the size of the white circle shown in the screenshot 16.1).  
After you release that click, move your cursor around, and you will be adjusting the 
length of your cylinder.  When you’ve got at the right length, one last left click will finish 
your cylinder.  The finished cylinder is shown in screenshot 16.2.  The right mouse 
button is used to cancel your cylinder creation if you mess something up. 
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         16.1 
 

 
         16.2 
 
 
17) You may notice a few of things: the cylinder isn’t in the right place, it probably isn’t 
long enough, and it may not be orange.  Don’t worry, we’ll fix the first two and the last 
doesn’t matter as gMax randomly selects a color for new objects (though the orange 
looks pretty sweet).  First we’re going to discuss two more things in gMax: the “Select 
and Move” tool (in the main toolbar: ) and the “Gizmo” (yes, it’s a stupid name).  
First, let’s select the “Select and Move” tool, and when we move it into a viewport near 

those weird red, green and blue arrows, the cursor looks like this: . 
 
18) Those weird arrows are the “Gizmo” which represent the different axis of movement 
that are available.  You can only move on one axis at a time, so gMax indicates which 
axis you are on by turning the shaft of the appropriate Gizmo arrow a light orange colour.  
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The following screenshots show the Perspective viewport with the Gizmo and a closeup 
of the Gizmo with the “z” axis selected. 
 

 
 

 
 
19)  The details of how to move things around in gMax are best discovered through 
experimenting, so play around with your cylinder a bit.  When you’re done, it should look 
something like the next screenshot. 
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20) Now we’re going to do something about the length of that blade.  You may have 
noticed when you were creating your cylinder that there was a rollout for “Parameters” 
that showed numbers for the radius and height as well as a few other things.  Adjusting 
these numbers while creating the cylinder is one way to get the cylinder the right size, but 
in our case, it’s easier to get the size right if the cylinder is in the right place.  Because 
our cylinder is already created, we’ll have to modify it using the tools under the “Modify” 

tab (on the command panel: ).  Let’s start by clicking on that tab to open it up. 
 
21) Under the “Parameters” rollout, you’ll see all of those parameters that were 
mentioned in the last step.  The subtle difference is that now we’ve “created” the cylinder 
so we have to use the “modify” parameters instead of the “creation” parameters.  Just 
play with the “Height” parameter until the cylinder looks about the same length as our 
guide blade.  Don’t worry if your height (or any other parameter) is negative just so long 
as it looks right in the viewport.  Here is the cylinder with the adjusted height.  The 
“Perspective” viewport is being used to illustrate the cylinder, but the “Left” viewport 
was most useful in making sure it was the right length. 
 

 
 
22) Still under the “Modify” tab and still under the “Parameters” rollout, we’re going to 
make our “blade” a bit less round: change the “Sides” parameter to ‘4’.  A square sword 
may seem little better than a round one at this point, but don’t worry, we’re going 
somewhere with this.  Here is the squared blade: 
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23)  To do some really interesting modifications to the blade, we need to convert it to an 
“Editable Mesh.”  This is done by right-clicking on the word “Cylinder” in the big grey 
box.  The “big grey box” is located under the “Modifier List” dropdown. That dropdown 
is under the name of the object we’re modifying (probably Cylinder01).  The “Object 
Name” textbox is located under the command panel.  Your right-click will open a menu, 
and you should choose “Convert To: Editable Mesh” from that menu.  That was a bit 
confusing, but locations of “big grey boxes” can be challenging to describe.  Hopefully 
the screenshot helps. 
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24) You may notice that some of the rollouts under the “Modify” tab have changed.  
Under the “Selection” rollout, click the “Vertex” button (three little red dots--err vertices: 

). 
 
25) Choose the “Front” viewport and draw a selection box around the left and right 
vertices (as opposed to the top and bottom vertices).  If you can’t manage to do this 
magic selection in one shot, you can add to your existing selection by holding down the 
“Ctrl” key while selecting (conversely, you can remove things from your existing 
selection by holding down the “Alt” key while selecting).  These selected vertices should 
now be red as in the screenshot. 
 

 
 
26) Choose the “Select and Non-Uniform Scale” tool (it’s in the main toolbar in a flyout.  

The other icons in the group look similar, but this is the tool you want: ). 
 
27) Move your cursor back into the “Front” viewport and put it over the ‘x’ axis on the 
Gizmo.  Your cursor should now look like this: . 
 
28) Click and drag and the scaling tool should narrow and widen your “cylinder”.  
Narrow the cylinder so that it looks more like a blade.  I’ve removed the guide blade in 
this screenshot so you can see the modified blade better. 
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29) Switch to the “Left” viewport and “Max/Min toggle” (in the navigation tools: ). 
 
30) Our goal in the next few steps is to make our “cylinder” look more and more like a 
sword blade.  This will be done by moving and scaling various vertices.  The vertices are 
a bit hard to reference, but with the descriptions and the screen shots, you should be fine.  
First, we’re going to lengthen the blade and lop off a few extra vertices.  Draw a selection 
box around all vertices except the ones by the hilt. 
 

 
 
31) Right-click somewhere in the viewport (to open the quad menu) and choose “Move”. 
 
32) Using the Gizmo and the “Move” tool, slide the selected vertices to the left so that the 
box created by the right-most selected vertices and the unselected vertices is about 3/4s of 
the sword--don't worry, there's a screenshot. 
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33) Select the six vertices that are farthest to the left and hit the delete button (you can 
undo and try again if your result doesn’t look like the screenshot). 
 

 
 
Note: If, when you are making your own sword, you find that you need more vertices to 
play with, you can create them by slicing.  When in the “Modify” tab (command panel: 

), under the “Edit Geometry” rollout, there is a slicing section with the buttons “Slice 
Plane” and “Slice”.  If you click “Slice Plane” button, a plane will be drawn on the 
polygon that you’re modifying (in our case, the blade cylinder).  This plane can be moved 

around using the “Select and Move” tool and the “Select and Rotate” tool ( ).  
When the plane is where you want it, clicking the “Slice” button will create new vertices 
corresponding to the plane you’ve sliced on and the sides of your polygon.  If it doesn’t 

make sense, just try a few slices, you can always “Undo” it ( ). 
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34) Select the left-most column of vertices (we’re still working in the “Left” viewport).   
 

 
 
35) Under the “Edit Geometry” rollout (still under the “Modify” tab), scroll to the very 
bottom of the rollout, and click the “Collapse” button. 
 

 
 
36)  That’s starting to look more like a sword!  This is a good time to mess with the other 
vertices in your blade.  Try using the “Uniform” and “Non-uniform” scaling tools or just 
“Move” them around.  One thing to be aware of while doing this is the number of 
polygons you are making.  It’s not important what a polygon is, but it is important to 
keep the number as low a possible.  More polygons mean slower game performance.  The 
polygon counter will tell you how many polygons you are using and can be found under 

the “Utilities” tab (in the command panel: ).  Clicking this button activates it: 
, and the window it opens looks like this: 
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37) Since we’re only working on the blade, you need only concerned be with the 
“Selected Objects” field.  When we’re exporting, we may be interested in the “All 
Objects” field.  The official word is “try to keep your whole model under 180 polygons,” 
but in the process of making this tutorial, there were many models made in the 270 
polygon range with no problems.  If you make a crazy one, make sure to test it a few 
times in-game to see if it causes slowdown or errors.  Here is a sample custom blade: 
 

 
 
 
38) Now we can get rid of the guide blade: under the “Display” tab (in the command 

panel: ), under the “Freeze” rollout, choose “Unfreeze by Name”.  
 
39) From the “Unfreeze Objects” window, choose “g_WSwLs_t_011” from the list, and 
click the “Unfreeze” button. 
 

40) Click the “Select by Name” tool (main toolbar: ) tool, choose 
“g_WSwLs_t_011” from the list, and click the “Select” button. Then just hit the delete 
button to delete the guide blade. 
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41) Let’s go back under the “Freeze” rollout and click “Unfreeze by Name” again.  
You’ll notice in the “Unfreeze Objects” window that there is still an object with a “_t_” 
in it (“WSwLs_t_011” to be exact).  This is the “model base” for the blade.  Model bases 
are required for NWN models and are a reference point for displaying the model in the 
game.  If you were building a model from scratch, your first step would have been to 
create this base.  We need to connect the old base with our new blade so that NWN 
knows they’re together.  We do that by using the “Select and Link” tool, but first, we’ll 
select the model base from the list and click the “Unfreeze” button. 
 
42) The model base should change from the “frozen” color to a light blue square-y thing.  
Below is a screenshot with an unfrozen model base.  It should be noted that while you 
can see the other parts of the guide sword (the cross-guard and the grip), you can’t see 
their respective model bases.  The reason for this is that all the model bases are 
occupying the same spot, making it look like there is only one. 
 

 
 
43) To link the blade with the base, we’ll use the “Select and Link” tool from the main 

toolbar ( ).  Click the tool to start the magic. 
 
44) Click your new blade to select it (this is the “select” part of “Select and Link”). 
 

45) Using the “Select by Name” tool (main toolbar: ), select “WSwLs_t_011” from 
the list (if it’s not there, you may have forgotten to unfreeze it).  You may notice that the 
“Select” button that was there the last time we used “Select by Name” has been replaced 
by a “Link” button (the window itself is now called “Select Parent” instead of “Select 
Objects”).  This means that gMax will link the model base (which you’ve just selected) to 
the blade (which you had previously selected).  The fact that the button now says “Link” 
is the best indication you’ll get that all of this is working.  Here is a screenshot of the 
“Select Parent” window: 
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46) We should take note of a couple of things before moving on.  First, with the model 
base selected (click on it or use “Select by Name”), have a look at the text box directly 
under the command panel.  This is the name of the object selected, and it should look like 

this:  (earlier it was dubbed the “Object Name” textbox and 
will be referred to as such from now on).  Let’s take this opportunity to explain why it’s 
called “WSwLs_t_011”.  Each of the characters in the name have a meaning (obviously).  
Here is an attempt to explain that meaning: 
 
Note: For the purposes of this example, “colour” will be spelled using the American 
dictionary so that my notes will match the screenshot. 
 
(W)eapon 
(Sw)ord 
(L)ong(s)word 
(t)Position: can be t (top), m (middle), or b (bottom) 
Model number (2 digits) 
Color number (1 digit) 
so WSwLs_t_011 = Weapon, Sword, Longsword, top piece #10, color #1 
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To give you a better idea of what Model number and Color number are all about, check 
out this screenshot: 
 

 
 
As you can see, by changing the dropdown for Top, Model you change the blade model.  
You may recognize this sword as it’s the “01” sword that we used as a guide.  We’re 
going to make our new sword “09” so we don’t overwrite any existing blades.  I’m going 
to take a moment here to discuss “color” as well.  “Color” essentially represents the 
colour of the metal or, in gMax terms, the colour of the texture we apply to the model.  
We’ll get into the texturing later, but generally, when you make a model in gMax, you 
should make it in 4 colours.  NWN expects your model to have four colours, so it can 
cause problems if it doesn’t.  One last thing to note: do you see the 2d picture of the 
sword in the bottom-right of the screenshot?  That’s a “backpack” picture of the sword.  
This picture is created using an image editing tool like Photoshop or GIMP and is also 
expected by NWN and can cause problems if it’s missing.  Don’t worry; we’ll get to all 
these things in time.  It was just a good time to introduce them, while we have a handy 
screenshot for illustration. 
 
47) Freshly armed with our naming knowledge, we’re going to rename our blade to 
correspond to model # 09.  All this requires is changing “WSwLs_t_011” to 
“WSwLs_t_091” in the “Object Name” text box.  If you’ve been paying attention, you 
may know that we’ve only changed the name on the model base.  That’s fine because 
NWN doesn’t really care about anything but the model base all will be fine as long as 
your model is linked to the base.  For future reference, you should rename your blade 
(currently called Cylinder01) to something more representative (if you use more 
cylinders in your model, things can get confusing).  For example, “Ls_t_09” isn’t a bad 
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choice, but it’s totally up to you as none of the programs will pay any attention to this 
name. 
 
48)  Now that you’ve finished with the blade, freeze it so that you can move on to the 
next part.  In case you’ve forgotten, a good way to freeze it would be to click on the 

“Display” tab in the command panel ( ), scroll down to the “Freeze” rollout, choose 
“Freeze by Name,” select your blade and model base from the list (could be “Ls_t_09” 
and “WSwLs_t_091”), and click the “Freeze” button. 
 
49)  Having completed the blade, it’s now a good time to make the cross-guard (_m_) 
and the grip (_b_).  As the steps are essentially the same as they are for the blade, the 
creation of these pieces will be left to you.  One suggestion is that you keep things simple 
for your first sword.  Use only a single object for each piece.  Perhaps a “Box” object for 
the cross-guard and another “Cylinder” object for the grip.  Remember, the scale in the 
NWN is pretty tiny, so don’t waste a lot of time being fancy.  The tutorial sword ended 
up looking like this: 
 

 
 
Exporting: 
 
Out of the labyrinth: 
 
50) Now that you’ve got a sword of some kind, let’s see how it looks in the toolset.  
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Unfreeze your blade and its corresponding model base (if you don’t know how to do this 
by now, you’re in trouble).  Select the model base (“by Name” is probably easiest) and 

click the “Modify tab” on the command panel ( ). 
 
51) Under the Modify tab, under the “MDL Base Parameters” rollout, under the “Export” 
heading, you should see a “Dir” textbox.  Change the contents of that textbox to your 
working directory (C:\NWNScratch\).  It should look like this: 

.  
 
52) Still under the “MDL Base Parameters” rollout, under the “Export” heading, click the 
“Export Model+Anim” button. 
 
53) If there are no errors (and there should not be), you should find the file 
“WSwLs_t_091.mdl” file in your working directory.  While you’re there, let’s grab the 
backpack picture I was talking about earlier. 
 
54) In the C:\NWNScratch\weaponslib\WeaponInfo\MDLsAndIcons\SwordLongSword 
directory, you should see 6 files: 
 

 
 
55) The three files ending in “.MDL” are the models you used for the “guide” sword.  
The three ending in “.TGA” are the backpack images that we’re interested in.  Normally, 
you would open these up in an image editing program and massage them until they 
looked similar to your model.  In our case, we’re just going to reuse these images 
essentially unchanged.  The simplest way to do this is to copy these three “.TGA” files to 
C:\NWNScratch (where your new models should be), and rename them with your new 
model number (for example: iwswls_t_011.TGA will become iwswls_t_091.TGA).  
Make sure that you have images for each sword piece, and they are correctly named.  If 
this isn’t done, you will have problems.  Your working directory should now look like 
this: 
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“Haking [sic]”: 
 
56) Now you’re ready to get it in the game.  The easiest way to do this is to create a 
HakPak for it.  A HakPak is just a collection of modifications that can be applied to a 
module.  It may include new characters, special rules, customized weapons, sounds, and 
lots of other neat things.  Making a HakPak is pretty simple with the tools provided by 
BioWare.  In your NWN directory (should be: C:\NeverwinterNights\NWN), in a folder 
called “utils,” you’ll find a utility called “nwhak.exe.”  Double-click on it to run it. 
 

 
 
57) A window entitled “BioWare Hak Pak Editor” should open.  All you need to do is 
drag your six sword files and drop them into the big table at the bottom of the window.  
Then give your HakPak a title (and a URL and Description if you like).  It should look 
something like this when you’re done: 
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58) Your HakPak is finished.  Under the File menu, choose Save, and in the “Save As” 
window, name your file “newlongsword9,” and click the “Save” button. 
 
59) Close the HakPak Editor, and open the Aurora Toolset.  In any module, under the 
“Edit” menu, choose “Module Properties.” 
 
60) In the “Module Properties” window that opens, choose the “Custom Content” tab. 
 
61) In the dropdown box (the one just above the “Check for Conflicts” button), choose 
your HakPak from the list, click the “Add” button, and click “OK.” 
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62) A “Warning” window will pop up letting you know that HakPaks are really scary and 
can cause all kinds of problems.  This is true, but our HakPak is fairly simple and 
shouldn’t cause any problems.  Just click the “Yes” button. 
 

 
 
63) Then you should get a “Build Module” window letting you know the results of the 
“check” on your HakPak.  If you’ve done everything right so far, you shouldn’t get any 
errors, and your window should look like the screenshot below.  Just click “Done” to 
finish adding the HakPak. 
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64) Now, just make a new longsword, edit the longsword’s properties, and go to the 
“Appearance” tab.  Change all of the “Model” dropdowns to “9” and make sure that all 
the “Color” dropdowns are set to “1” (as we haven’t made any other “Colors” yet).  
Recognize that sword? 
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65) Wow!  You made a sword and put it in the game!  That’s pretty exciting!  You may 
notice a couple of things about that sword.  First off, it’s kind of smooth for sword 
(especially the blade), and secondly, it looks a bit too shiny to be a real sword.  
Smoothing and “chroming” are default settings that can be changed.  Let’s get to it. 
 
Smoothing (or not): 
 
66) Back in gMax (hopefully, you haven't closed anything as I haven't told you to yet!), 
unfreeze your sword blade (Display tab, “Freeze” rollout, “Unfreeze by Name”, choose 
“Ls_t_09”, and click the “Unfreeze” button), select your sword blade, and click the 

“Modify tab” (command panel: ). 
 

67) Under the “Selection” rollout, choose “Face” (just under the rollout title: ), and 
draw a selection box around your sword blade to select all of its faces.  In any viewport 
but “Perspective”, the edges of the blade will turn red when selected. 
 

 
 
68) Back under the “Modify”tab, under the “Surface Properties” rollout, you should find 
a button labeled "Auto Smooth" with a text box next to it.  Let's change it to something 
low.  Try ‘2’ and see how it looks. 
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69) In the screenshot, you can see that the edges are much sharper now.  In this case, they 
are too sharp, and there are too many of them.  Putting ‘20 ‘in the “Auto Smooth” textbox 
seems to give the right amount of smoothing for a blade.  That's pretty much it for 
smoothing.  If you're not happy with the look of the other pieces, smooth or unsmooth 
them as you see fit. 
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Chrome Swords are for Pixies: 
 
70) We’re going to get rid of that silly chrome and replace it with some real metal 
textures.  In the NWmax window, “General Utils” rollout, click the “Chilli Skinner” 
button to open the “ChilliSkinner” window and related tools.  Before we start texturing, 
make a backup of your sword model as things can get a bit hairy. 
 

71) Freeze everything except the sword blade (Display tab: , “Freeze” rollout) then 

select the sword blade (perhaps using “Select by Name” from the main toolbar: ). 
 
72) In the “Chilliskinner” window, under the “Chilli's Big Tool Set” rollout, you should 
see a text box labeled "Detach Angle" with the value ‘30’ in it (if the value isn't ‘30’, 
change it so that it is).  Under this text box, there is a line of buttons: 

.  Click the “Auto Detach” button: .  This separates the 
"sides" of the sword blade so that they can be individually textured. 
 

73) Click the "Select by Name" tool (main toolbar: ).  You should see a list of 
numbered “Objects.”  The number of objects will depend on how you built you sword. 
Our sample sword was fairly simple, so it only had 5 objects: 
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74) The previous step is a good check to make sure that the detach worked correctly.  The 
next few steps are a bit weird so they need special explanation before we get at it.  We're 
going to clone all sides of the blade and hide them (Don't worry, Chilliskinner does this 
all for us).  This is so that gMax "remembers" what the sword blade looks like.  Then 
we're going to flatten the sword blade (leaving the cloned blade in place) so that we can 
texture it.  Apparently, you can't easily texture a 3d object so flattening is the only way to 
go.  When we've textured our flattened blade, we tell gMax to “smush” (yes, that’s the 
technical term) the flattened, textured surfaces back together with the cloned versions that 
are still in their original places.  This way, we get our 3d sword blade back with all the 
nice textures on it.  Sounds complicated, but that's what tutorials are for.  Let’s get to it. 
 
75) Select all parts of the blade.  We’ve discussed a number of different ways to do this 
and any of them will work. 
 

76) In the “Chilliskinner” window, click the “Clone” button: .  If you’re paying 
attention, you may have noticed that the “Clone” button just to the right of the “Auto 
Detach” button that we just used.  As it turns out, Chilli is no idiot.  He’s set up the 
buttons so that you can essentially work left to right, top to bottom.  Don’t worry, the 
tutorial will still tell you which buttons to use and when. 
 
77) To make sure that your clone worked, under the “Display” tab (command 

panel: ), under the “Hide” rollout, click the “Unhide by Name” button.  In the 
“Unhide Objects” window, there should be a clone here for every part of the blade.  If 

there isn't, undo your last step (the “Undo” button in the main toolbar: .  This may 
be a good time to suggest using the undo/redo buttons within the “Chilliskinner” window.  
They are more effective on Chilli’s actions than the main toolbar ones) and select the 
blade more thoroughly before cloning.  By the way, don’t actually “unhide” anything.  
The Chilliskinner “Clone” tool clones the selected object and automatically hides it.  
We’d like it to stay hidden, we were just making sure that everything worked. 
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78) Back in the CSW (“Chilliskinner” window), we’re going to click a bunch of buttons 
in a row.  Before we start, make sure that all of your “Objects” (no clones) are selected.  

Ok, here goes: “Unfold Poly(s)”: , “Flatten Poly(s)”: , “Optimize Poly(s)”: 

, and “Arrange Polys”: .  If you get confused as to which buttons you’ve 
pushed and which you haven’t, just “undo” until you know where you’re at, then start 
again.  Under the “Edit” menu, the first option is “Undo” and often tells you what it’s 
going to undo.  This can be helpful in figuring out which step you’re at.As mentioned 
earlier, Chilli has provided special undo/redo buttons in his window which work better on 
his actions, but they don’t provide any on which task they are affecting. When it’s all 
done, your sword parts should all be nicely laid out like this: 
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79) Texturing is an expensive process, so we’re going to make it easier on the computer.  
If two parts are identical, moving one on top of the other tells gMax to just use the same 
texture on both pieces.  This little action saves textures.  Using the “Align” tool (main 

toolbar: ), we’ll move identical parts so that they are all stacked on top of one 
another.   
 
80) Select the “source” or “current” piece (the piece you’d like to move), click the 
“Align” tool, and click the “target” piece (the piece you’d like to move “source” piece on 
top of).  If you do this correctly, this “Align Selection (Object##)” window should open 
(where “Object##” is the name of the “target” piece): 
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81) Play around with these settings as this tool can be quite useful for getting all kinds of 
things lined up in 3d space.  In the end, you’ll probably find that checking the “X 
Position” and/or “Y Position” boxes are enough in most cases.  Click the “Ok” button 
when you’ve got the pieces lined up. 
 
82) If you use the screenshot in Step 78 as a guide, when all the “stacking” is done, you 
should have only three pieces showing.  In this example, the pieces have also been moved 
close together so that one small texture can easily be used for all of them.  
 

 
 
83) We’re just about ready to texture, so we’re going to tell gMax to “remember” where 
we are just in case something goes horribly wrong during texturing.  Under the “Edit” 
menu, choose “Hold” to accomplish this. 
 
84) Select all of your blade parts, and back in the CSW, click the “Attach Polys” button 

( ). 
 
85) If you check the “Select by Name” window, you should now only have one object 
(mine was “Object01”) if the “attaching” worked correctly. 
 
86) Now things get weird again.  We’re going to take a screenshot of our pieces, open 
that screenshot in an image editing suite (GIMP in this tutorial), apply our textures to that 
screenshot, and bring it all back to gMax.  To make a nice picture, use the “Pan” 

navigational tool ( ) and the “Zoom” tool ( ) to center the “Top” viewport, unfreeze 
and hide the other parts of the sword (cross-piece and grip), and unselect the flattened 
sword (it should turn green). 
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87) To actually take the screenshot, just hit the “Print Screen” button.  It should be 
located in a group of three buttons in the top right corner of your keyboard. 
 
88) Open GIMP (Under the “Start” menu-->Programs-->Graphics, look for this icon: 

). 
 
89) You should see the main window for GIMP (cleverly titled “The GIMP”) and a 
window for tips.  Either close or move the tips window out of the way, and you’re left 
with something like this: 
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90) Under the “File” menu, choose “New.” 
 
91) In the “Create a New Image” window that opens, change both “Width” and “Height” 
to 256, and click the “Ok” button.  The reason for those dimensions is that NWN likes 
textures that have dimensions which are multiples of 64.  Don’t ask why, just blindly 
obey. 
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92) A new window should open entitled “Untitle-1.0 (RGB, 1 layer) 256x256.”  In this 
window, under the “Edit” menu, choose “Paste.” 
 
93) You’ll notice that your screenshot is too big to show in the 256x256 image.  We don’t 
really need the whole screenshot, we just need the part that shows our sword blade in the 
“Top” viewport.  To get the image into the right spot, use the “Move” tool (main GIMP 

window: ). 
 
94) Once you selected the “Move” tool, click and drag somewhere on your image, and it 
should move with your drag.  Move it so that your “Top” view of the sword parts is about 
all you can see. 
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95) You may need to move things around in gMax to get it right, but your goal is to get it 
positioned like the above. 
 
The Texturing Part: 
 
96) NWN has kindly provided us some premade textures that were used in the game.  To 
get at them, we’ll have to open them up in GIMP.  Under the “File” menu, choose 
“Open,” navigate to C:\NWNScratch\weaponslib\WeaponInfo\Textures, and choose 
“w_metal_text.TGA.”  You can, of course, use whichever textures you like, but for our 
example, we’ll use these ones for simplicity. 
 
97) When you click the “Open” button, a new window should open with a bunch of 
different coloured squares and rectangles.  These, my friend, are textures.  In the top right 
corner of the image, you will see two squares that are silvery.  In this example, we’ll use 
the darker (the lower) one.  Click the “Select rectangular regions” tool (main GIMP 

window: ), and draw a selection box around the texture you’d like to use. 
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98)  Don’t worry too much about getting the square exactly.  As long as it’s close and 
doesn’t include any parts of the other textures, everything will be fine.  Now you need to 
get this texture onto your blade parts image.  “Copy” your selection (Under the “Edit” 
menu, choose “Copy”). 
 
99) Click over to your blade parts image, and under the “Edit” menu, choose “Paste.”  
You should get something like this: 
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100) Because our example sword is going to be all one texture, all we need to do now is 
just move and stretch this pasted texture until it covers all my pieces.  It’s not any more 
difficult to add multiple textures, just follow the same procedure.  For illustration, we’ll 
go slowly through the “moving and stretching,” but these exact steps probably won’t 
work on your sword as things will be in different places. 
 

101) Using the “Move” tool (main GIMP window: ), move the pasted texture to the 
top left corner of my pieces. 
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102) Choose the “Scale layer or selection” tool (main GIMP window: ), click on our 
pasted texture, and drag the texture into a long narrow rectangle that covers all the pieces.  
While you’re scaling, the “Scale” window will pop up.  When you’ve got the rectangle to 
the right shape, release your click, and click the “Scale” button in the “Scale” window.  
Here is the “Scale” window (102.1) and the scaled texture (102.2): 
 

 
    102.1 
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    102.2 
 
103) We were just using our blade pieces as a guide, so now that we’ve got the texture to 
the right size, we can get rid of them.  The simplest way to do this is to create a layer with 
our texture.  Under the “Layer” menu, choose “New Layer.” 
 
104) Now let’s get rid of the bottom layer (our blade pieces).  Under the “Layer” menu 
again, under the “Stack” submenu, choose “Select Bottom Layer.”  If you didn’t do Step 
104 correctly, none of the “Stack” options will be available. 
 
105) Under the “Layer” menu (yet again), choose “Delete Layer.”  If you’ve done the last 
few steps correctly, you should have something like this: 
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106) We’re ready to get back to gMax now, so let’s save this thing up.  Under the “File” 
menu (still in our “Untitled” image), choose “Save.” 
 
107) In the “Save Image” window that opens, change the “Name” to “BladeTexture,” 
expand “Browse for other folders” (by clicking the “+” beside it) and navigate to 
“C:\NWNScratch”, then expand “Select File Type (By Extension)”, select “TarGa 
Image” from the list and click the “Save” button. 
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108) In the “Export File” window that opens, just click “Export.” 
 

 
 
109) In the “Save as TGA” window that opens, uncheck “RLE compression,” and click 
“OK.” 
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110) Open your gMax window again, and we’ll prepare the pieces to accept the texture.  
Make sure that your pieces are selected, then (in the CSW) click the “Apply Planar Map” 

button: .  This should “shift” your “selection indicators” (those little white lines 
that surround your selections) from an off-kilter rectangle (110.1) to an on-kilter 
rectangle (110.2). 
 

 
   110.1 
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   110.2 
 

111) Under the “Modify” tab (command panel: ), in the “Modifier List” dropdown, 
choose “UVW Map.”  To let you know you’ve succeeded in applying the transformation 
(the UVW mapping), it should appear above “Editable Mesh” in the list of 
transformations. 
 

 
 
112) We’re finally ready to apply the texture.  Open the “Material Navigator” (main 

toolbar: ). 
 
113) In the “gmax Material Navigator” window that opens, click the “File System” radio 
button on the left panel of the window, navigate to your texture in the middle panel, and 
click to select your texture on the right panel.  It will be outlined in red when it’s selected. 
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114) To get your material on the model, just click your texture on the right panel and drag 
it onto the model in the “Perspective” viewport.  I should note that if you don’t drag it 
quite onto the blade, you will see this warning: 
 

 
 
Don’t fret overmuch, just hit the “Cancel” button (hitting “OK” will make your new 
texture the background for the viewport, this can make things a bit hard to see so I don’t 
recommend it) and try the drag-and-drop again.  Your blade should now turn more metal-
ish.  If your texture doesn’t fit quite right or looks a bit weird, use the “Select and Non-
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Uniform Scale” tool (in the main toolbar: ). and the “Select and Move” tool (in the 
main toolbar: ) to resize it and adjust it so that it looks right. 
 

 
 
115) Cool, but still flat, right?  Let’s fix that.  Remember our clones?  We're going to use 
those to tell the textured pieces where they need to be.  It’s called “smushing.”  First, 

unhide your clones (Display tab: , “Hide” rollout, “Unhide by Name”) and select just 

the clones (main toolbar, “Select by Name”: ). 
 

116) Back in the ol’ CSW, click the “Attach Polys” button ( ).  To make sure this 
worked correctly, click “Select by Name” again and make sure that there are only two 
objects: 
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117) In the CSW, click the “Pick Source” button:  then select your blade 
pieces by name.  The button name should change to the name of your original blade 
object.  In my case, it was Object01. 
 
118) Click the “Pick Target” button:  then select your cloned blade by name.  
Again, the button name should change to correspond to the object you selected.  Here are 
the two changed buttons, ready for smushing: . 
 

119)  Still in the CSW, click the “Morph Source to Target” button ( ) and voila!  
That Chilli guy is a genius!  You should now have something like this: 
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120) Now we've got to weld the vertices.  We need to do this because gMax thinks that 
all these pieces (from your cloned bladed and your original) are just sitting next to each 
other, not combined into one blade.  Welding combines all of the pieces that are touching 
into single edges and vertices.  Just like real welding!  This cuts down on complexity of 
the model (and also just makes good sense).  Fear not, Chilli has a tool for this also!  Just 

click the “Select and weld ALL Verts” button ( ) while you’ve got the whole blade 
selected 
 
121) Unfreeze your model base, export your blade (don’t forget to link your blade to the 

model base before exporting: select your blade, click the “Select and Link” tool: , 

click the “Select by Name” tool: , and choose your model base from the list—
details in Steps 47-50), and check it out in the game.  For details on how to do this, check 
out Steps 55 to 70.  The only difference is that you need to make sure to put the newly 
exported blade model and your BladeTexture.TGA file into the HakPak. 
 
122) Now just apply these steps to the cross-guard and the grip.  The example sword 
ended up looking like this: 
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123) That’s it!  You’ve made a sword and put it in the game.  Congratulations! 
 

 


