
In this tutorial you will learn the basics (the very basics) of digital sound. You will learn 
to edit sound files and create your own. After playing a little with all that, you will see 
how to import these new sounds to the NWN Aurora Toolset to have custom sound in 
your games! 

So… Here we go! 

Sound is a series of mechanical compressions and rarefactions that successively pass one 
into another, transmitting through a compressible medium such as air. A sound wave can 
usually be represented graphically by a wavy, horizontal line; the upper part of the wave 
(the crest) indicates a compression and the lower part (the trough) indicates a rarefaction. 
The cause of sound waves is called the source of waves, e.g. a violin string vibrating 
upon being bowed or plucked. 

For human ears to detect sound, a change in pressure has to be strong enough to move the 
eardrums in the ears. The more strongly the pressure changes, the "louder" we perceive 
the sound to be. Human ear can recognize three different classes of sound: noise, tones 
and notes. 
 
The characteristics of sound are frequency, wavelength, amplitude and velocity.  
 
Now, after we know these concepts, let’s try to make things happen in our computers.  
 
AUDACITY 
Audacity is a nice little program that will let you work on the basics of sound editing and 
creation. We use it because it’s simple, and it’s free (that was a big reason). There are 
many other programs out there, from cool-edit to pro-tools. If you find this whole thing 
super interesting, you may want to check them out. No, those are not free, sorry. 
 
Noise and White noise: 
 
Noise is produced by combining sounds of different frequencies together. When you hear 
the sound of a river, or the sound of wind rustling through leaves, you are hearing noise.  
White noise on the other hand is a type of noise that is produced by combining sounds of 
all frequencies a human ear can hear together. 
 
Making white noise in audacity: 
 
1) Open Audacity. 
 
2) In the “Generate” menu, choose “White Noise.” 
 

3) Press the “Play” button ( ) to hear the white noise track you created. 
    Lovely isn’t it? 



Tone: 
 
A tone is a sound that repeats at a certain specific frequency. Any kind of sound can be 
represented visually. The wave displayed below is a 440-Hz tone. This particular tone is 
called a sine wave.  
 

 

A tone is made up of one frequency or a very small number of related frequencies. The 
alternative to a tone is a combination of hundreds or thousands of random frequencies. 
We refer to these random-combination sounds as noise. 

 
Making a 440.00 Sine Tone in Audacity: 
 
1) Open Audacity. 
 
2) In the “Generate” menu, choose “Tone”. 
 
3) In the “Tone Generator” window that opens, keep all the settings on default and click 
the “Generate Tone” button. 
 
4) Press the play button to hear the tone track you created. 
 
Note: You can ZOOM in and out of the sounds. To see the “waves” with more or less 
detail. Some times, like with the “tone” you just created, the default view will just show a 
wide uniform bar. To see the actual “waves”, you have to zoom in.  
 
To ZOOM, Use the “ctrl” key. 
                   Ctrl + 1 = Zoom In 
                   Ctrl + 2 = Zoom normal  (default view) 
                   Ctrl + 3 = Zoom Out 
 
 



Musical notes: 
 
A musical note is a tone. However, a musical-note tone comes from a small collection of 
tones that are pleasing to the human brain when used together. These particular tones 
have been given letter names, and also word names, like this:  

• 264 Hz - C, do (multiply by 9/8 to get:)  
• 297 Hz - D, re (multiply by 10/9 to get:)  
• 330 Hz - E, me (multiply by 16/15 to get:)  
• 352 Hz - F, fa (multiply by 9/8 to get:)  
• 396 Hz - G, so (multiply by 10/9 to get:)  
• 440 Hz - A, la (multiply by 9/8 to get:)  
• 495 Hz - B, ti (multiply by 16/15 to get:)  
• 528 Hz - C, do (multiply by 9/8 to get:)  

And the sequence repeats.  

The names are totally arbitrary, as with the fractions. It just turns out that they have a 
pleasing sound to human ears.  

One thing to notice is that the two C notes are separated by exactly a factor of two -- 264 
is one half of 528. This is the basis of octaves. Any note's frequency can be doubled to 
"go up an octave," and any note's frequency can be halved to "go down an octave."  

Creating the C major music scale in Audacity: 
 
1) Open Audacity. 
 
2) In “Generate” menu, choose “Tone”. 
 
3) In the “Tone Generator” window that opens, in the “Frequency” textbox, enter “264,” 
and click the “Generate Tone” button. 
 
4) Repeat steps 2 and 3 for each of the frequencies above. 
 
5) Press the “Play” button to hear the musical note track you created. 
 
 
 



Making Yourself Sound Weird: 
 
1) Open Audacity. 
 
2) Make sure that your microphone is connected correctly. 
 

3) Press the “Record” button ( ), and record a sentence of your liking.  If you  
can’t record, use the “I will save your village” wav file provided with this tutorial. 
 

4) After finishing the recording session, click the “Stop” button ( ).  Audacity 
will automatically create a wave track of your recording. 
 
5) From the “Effects” menu, choose “Change Pitch.”  Move the pitch from “F#/Gb” to 
“C#/Db” using the dropdown menu then click OK. 
 
6) Play your voice back to hear the pitch change.  Experiment with some of the other 
options under the “Effects” menu. 
 
7) When you’re finished playing around, under the “File” menu, choose “Save Project.” 
 
8) A warning will pop up to let you know that Audacity project files are awesome but 
don’t work in other programs.  Just click the “OK” button (and check the checkbox if you 
don’t want to be warned again). 

 
9) In the “Save Project As” window, navigate to your working directory, name the file 
VoiceTest, and click the “Save” button. 
 
 
 



Noise reduction: 
 
10) Noise is simply sound that you don’t want as part of your final recording.  Let’s get 
rid of some.  Using the “Select” tool (highlighted in the screenshot below), select some 
noise from your voice recording (some noise is also highlighted in the screenshot). 
 

 
 

11) From the “Effects” menu, choose “Noise Removal.”  
 
12) In the “Noise Removal” window that opens, click the “Get Noise Profile” button. 
 
13) Select the entire file (under the “edit” menu, under the “Select” submenu, choose 
“All”).  From the “Effects” menu, choose “Noise Removal” again.  
 
14) If you have a closer look at the “Noise Removal” window, you’ll see that we have 
done “Step 1” (selecting a few seconds of noise so that Audacity knows what to remove) 
and are now ready for “Step 2.”  Under the “Step 2” heading, use the slider to indicate the 
level of removal, then press the “Preview” button.  
 
15) You should hear a preview of your sound clip without the noise.  If you are not 
satisfied with the preview, you can adjust the slider or redo the noise profile that you 
created in steps 11 and 12. 
 
16) When you are satisfied with the preview, click the “Remove Noise” button. 
 
17) Save your file (under the “File” menu, choose “Save Project As”) as 
“VoiceNoNoise.” 
 
Making cool sound effects: 
There are a lot of cool sound effects and filters that you can download from the net. A 
quick search in google for “Audacity Plugins” will give you several websites to try stuff 
from. Some are good, some are bad. You try them!. 
 
Now, we are going to play with one of those effects. We already got the file for you, it is 
the one called “nseband.ny”, you should have downloaded it along this tutorial. To make 



it work, just copy the file into Audacity's “Plug ings” directory.  
(C:\Program Files\Audacity\Plug-Ins\). 
 
Close Audacity and open it again. In the “Generate” section there is a new option!. That 
is the plugin we just installed. Easy, right?. Now, off to work with it. 
 
1) Open a new project (under the “File” menu, choose “New Project”. 
2) Under the “Generate” menu, choose “Noise Band”. 
3) Enter the values (as shown in the screenshot) and click the “Debug” button. 
 

 
 
Note: We are making this, so that we have TWO tracks (stereo!). But, for it to work, 
make sure that before you try this step (4), you click somewhere else in the program, so 
that the first track created is NOT selected. Otherwise, instead of creating two separate 
tracks, it will just overlap them and make a mess. We don't want a mess. Those are bad. 
 
4) Repeat steps 2 and 3, but finish with the “OK” button instead of the “Debug” button. 
 
5) You have just created a stereo track for your sound effect.  The tracks are similar in 
many respects, but there are marginal differences between the two tracks that would add 
some additional subtleness to the effect to make it more interesting. 
 
6) Select both tracks. You can do this by the Menu, Edit--> Select--> All. 
     
    From the Effect menu select Phaser. Enter the values shown in the diagram below. 

 

 
 



Getting rid of stuff. Deleting from both tracks. 
 
1)  Pressing the shift key, select the waves as show below. Press the delete button. 
It at first, it seems it is only selecting one track,  once you are done selecting it, drag the 
mouse over to the other one, and the same selection will apply!. Really. 

 

 
 

2)  Repeat the same process for the beginning of the tracks as show below. 
 

 
 
3)  By removing the mentioned waves you will be able to loop you sound effect 
seamlessly. 
 
4)  Save your file as (I will save your village 03). 
 
5)  You have created an eerie atmospheric effect that can be exported to your module. 
 
Saving your files in the proper format 
 
Once you have the sounds you want to use in your game, you need to store them in the 
proper file format. Audacity saves the projects as “aup” files, but usually we need to 
work with either WAV files, or MP3s.  
 
To get your sound out as a WAV file, you just need to click on File --> Export As WAV. 
And that is it!. Just put a name and say where you want it saved!. 
 



For the mp3s though, things are a bit tricky the 1st time. The installation of Audacity does 
not support MP3s, so you need to download a library to make that happen. The files you 
need to make that work are among the others that come with this tutorial. Ok? 
 
Now, off to make it happen. Open that zip file called “lame-3.96.1.zip”, get those files 
and place them somewhere that you know in the computer. The best is to place them in 
the Audacity folder too. (C:\Program Files\Audacity\). 
 
Once you have them there, you need to let Audacity know where they are. For that, go to 
File --> Preferences, and open the “File Formats” tab. There is an MP3 export section in 
there, click on “Find Library”. 

 
You will be told some stuff about Audacity and mp3s, just say YES, and then locate 
where you placed the library a couple minutes ago. (As you can see, you can change the 
Bit Rate too. The higher it is, the better quality you will get in the sound, but the larger 
the files will be). 
 
Once you have done this, close Audacity and open it again.  
 
Now, to save a file as an mp3, just go to File--> Export As MP3!. 



Placing custom sounds in your game 
 
Ok, we learned to edit sound, make our own, and even to put it in the proper file format. 
Now, how do we put it in our game?!. Keep reading to find out.  
 
First of all, here we used Audacity. Because it is a free tool, and it does the job quite well. 
But, as we told you, you could use any other sound editing program. As long as in the 
end you have the wiles in WAV or MP3 format, you can place them in your game. 
 
Once you have custom sounds, you have to use this  one thing called the Hak Pak editor. 
It is part of the tools that come with Aurora to help you build a game.  Hak Paks are what 
you use to place custom stuff into your game. Sound, art, 3D models, etc. 
 
1)  To run this little application, go to where NWN is installed, and you will find it in the 
“utils” folder. (The default location is C: \NeverwinterNights \NWN \utils)  
 
The name of the file is: nwhak.exe 
 

  
2)  Place the new sounds in the Hak through the menu, using Resource --> Add. You can 
do this several times, to add several sound files. As you do this, the new files are 
displayed in the list. Once you are done, save this hak file into the HAK folder of the 



NWN installation. (They have to be on that folder!). 
 
3) Once you have all those sounds in your Hak file, you can add it to a module. Open any 
module that you may have. We will place this new sound into it. 
 
Go to Edit -- > Module Properties, and there open the Custom Content Tab. 
 
4) In the drop down menu in the Custom Content Tab, you should see a reference to the 
hakfile you created. Select it and click on the button to the right... Yes, the one that says 
“Add”. 

 
When you add stuff, sort of a “warning” will appear. Dont worry, say YES. A bunch of 
things will happen, and bars indicating different sorts of progress as your module is 
updated will be shown. That is quite ok, and will happen every time.  
 
Note: If you add content to your modules using hakpaks, people will not be able to play 
your module if they don't have the hakpak!. So, whenever you distribute your module, 
make sure you give people all the files they need to play it correctly. Other than the .mod 
file, of course. :-P 
 



5) To actually place the sound in your module, we will use the Sound Wizard. On the 
Menu click on Wizards--> Sound Wizard. The wizard is a self explanatory step by step 
guide. For each step, things to have in mind: 
 

1) Assign Palette Category 
Assign the sound to some category. This is about organization, be 
consistent!. A good way is to just place all your sounds in the Special -> 
Custom Palette (Click next) 

2) Timing 
Seamlessly looping will keep on playing the sound... Good for background 
ambient effects, like wind and stuff. Or just a musical score. 
Single-Shot(s) are the way to go for assigning a sound to some event, a 
special effect, and things like that. 

3) Positioning 
Area-wide 
The sound will play in the same way, regardless of where the player is. 
Positional 
The sound comes from a certain position, so it will seem to come from the 
“left” of the player, or the “right”, for closer or farther away.  

4) Wave List 
Here, when you click on “Add Sounds” it takes a while, and then all the 
possible sounds available are listed. Down below, to the left, you can 
make it so that you only see the resources from HakPaks. Do that, it makes 
things easier!. 
Select your sound, and click on OK. If you want to Add more sounds do 
so, if not, just click “Next” on the Wizard 

5) Name 
Assign some good name to your Sound, it should make sense and be easy 
to remember. Then click on “Finish”.  
If the checkbox that says “Lauch Properties Dialogue” is selected, once 
you created the sound a screen will appear that will let you customize it a 
tad more. The Tabs that say Positioning and Advanced are interesting, 
play with those parameters if you feel like. They are self explanatory. 
 
 

 



Your sounds are now listed in the Sound Palette, under the Custom section. 

 
6) Click on it and paint it in your scene like any other object!. If you set it as “Area 
Wide”, it doesn't matter where you place it. The sound will be heard all over the place. If 
you made it Positional, place it where you want the sound to come from. 



As usual, there are several different ways to do this same thing. And this tutorial just 
covered the very basics of sound in the Toolset. You can always asks the TA's in the Lab, 
and search online for more tips. One of the best resources are the forums that the people 
at Bioware setup. (http://nwn.bioware.com/builders/) 
 
Cheers and enjoy!. 
 
Ps. (there is an appendix on the next page!).  



Appendix - Compression 
For some people this may be quite obvious, but for a lot of you it isn’t. So we decided to 
talk about it here. Compression! Sampling rates! File quality! Oh my! 
 
We all use images and graphics much more than sounds for presentations, papers, etc. So, 
a good analogy is to talk about image compression. It is always a tradeoff, file size vs. 
image quality. If you want “the very best”, you will have to pay with a huge file. But 
sometimes, having less quality doesn’t really show that much, and the difference in file 
sizes is impressive. 
 
Take for example, this image: 

 
 
The original TIFF file is HUGE! It saves the information almost pixel by pixel. And that 
is a lot… By compressing a file, you are saying “Ok, from here to here, we have X color, 
and from here to here, Y color”, and so on. When compressing, you care more about 
“regions” of color.  
 
A TIFF file, with only a large white square, would still be large, storing way too much 
information. A compressed JPEG file would say “Oh yes, this whole thing is white”. On 
that example above, it is hard to tell the difference between each image. You would 
actually have to zoom in a lot, to be able to tell a worthy difference. So, it all depends on 
what you want it for. Printing in a huge billboard or just a small graphic in a website? 
 
This is also true with sound. You can use different sampling rates and compression 
options to get much smaller files, and with sound, that is always a huge deal. Just like in 
the images, to be able to tell the difference, you’d need a super high quality sound 
system, with a lot of channels. With a regular two-speaker system at a normal volume, 
most people can’t tell the difference between low and high quality sounds. 
 
To play with this, in Audacity go to File  Preferences  File Formats. There, you can 



try different sampling rates for mp3 files. Depending on how “rich” your original sound 
is (and the volume at which it is meant to be played, quality of sound system, etc.) you 
will notice a large difference in file size when playing with different sampling rates. 
 

 


